Cara Mengubah Minsdkversion di Flutter

Ketika sedang bekerja dengan Flutter dan menggunakan paket-paket eksternal seringkali anda harus mengubah Minsdkversion sesuai dengan paket yang anda gunakan.

Ada beberapa cara untuk mengubah Minsdkversion di Flutter, untuk lebih jelasnya ikuti artikel berikut ini.

Flutter Sebelum Versi 2.8

  1. Buka file “build.gradle” pada “Project > android > app > build.gradle”.
  2. Pada “defaultConfig” ubah nilai “Minsdkversion”.
  3. Jalankan “flutter clean”.
minsdk flutter before 2.8

Flutter Setelah Versi 2.8

  1. Buka file “local.properties” pada “Project > android > local.properties”.
  2. Pada baris terakhir tambahkan:
flutter.minSdkVersion=21
flutter.targetSdkVersion=30
flutter.compileSdkVersion=30
  1. Kemudian pada “build.gradle” ubah menjadi.
minSdkVersion localProperties.getProperty('flutter.minSdkVersion').toInteger()
targetSdkVersion localProperties.getProperty('flutter.targetSdkVersion').toInteger()
minsdk flutter 2.8
  1. Jalankan “flutter clean”.
TOP TUTORIALS:  Cara Mudah Mengaktifkan Opsi Pengembang di Android